Lompat ke konten Lompat ke sidebar Lompat ke footer

Konfigurasi OSPF Single area pada Router Cisco

OSPF kepanjangan dari Open Shothest Path First adalah salah satu Routing protokol pada kebanyakan Router yang berfungsi untuk mendistribusikan informasi jaringan dari satu Router ke Router lainnya. Dengan menggunakan OSPF pada jaringan kita dapat mengaktifkan dynamic routing sehingga dalam konfigurasi routing tidak sesukar Static Routing.

Konfigurasi OSPF Single area pada Router Cisco

OSPF merupakan protokol IGP (Interior Gateway routing Protocol) yang artinya OSPF hanya dapat mendistribusikan informasi Routing dalam satu AS yang sama saja, setiap informasi routing dalam OSPF disebut dengan LSA (Link State Advertisement), sekumpulan LSA tersebut disimpan dalam LSDB (Link State Database) setiap Router.

OSPF LSA

Informasi yang dikirimkan oleh OSPF disebut dengan LSA karena OSPF merupakan Link State Routing Protocol, LSA sendiri memiliki 7 tipe yang masing-masing memiliki fungsi tersendiri, pada posting kali ini yang akan sering muncul adalah LSA tipe 1 (Router-LSA).

LSA Tipe 1 akan dibuat oleh seluruh Router yang menjalankan OSPF, isi dari LSA Tipe satu adalah seluruh Link/Interface yang dimiliki oleh Router yang membuatnya, LSA Tipe 1 akan dikirimkan kesemua Router dalam satu area yang sama saja, sehingga masing-masing Router akan mengetahui Router kawannya yang masih dalam satu area.

Cara konfigurasi OSPF pada Router Cisco

Router(config)# router ospf [process-id]
Router(config-router)# network [ip network] [wildcard mask] area [area-id]
  • Process ID berisifat lokal untuk membedakan satu proses dengan proses lain dalam satu router.
  • Wildcard merupakan kebalikan dari subnet mask, Wildcard = 255.255.255.255 – Subnet Mask.
  • Konfigurasi OSPF kali ini masih single area untuk jaringan yang cenderung kecil

Lab OSPF single area pada Cisco

Konfigurasi OSPF kali ini masih single area untuk jaringan yang cenderung kecil berdasarkan topologi dibawah ini :
Konfigurasi OSPF Single area pada Router Cisco

Pada lab kali ini seluruh Router berada dalam area 1 OSPF.

Konfigurasi Awal

Pertama kita lakukan konfigurasi awal seperti hostname dan IP Address pada masing-masing Router.

Router R1

R1(config)# int lo0
R1(config-if)# ip addr 1.1.1.1 255.255.255.255
R1(config-if)# exit
R1(config)# int g0/0
R1(config-if)# ip addr 192.168.12.1 255.255.255.0
R1(config-if)# no sh
R1(config-if)# exit

Router R2

R2(config)# int lo0
R2(config-if)# ip addr 2.2.2.2 255.255.255.255
R2(config-if)# exit
R2(config)# int g0/0
R2(config-if)# ip addr 192.168.12.2 255.255.255.0
R2(config-if)# no sh
R2(config-if)# exit
R2(config)# int g0/1
R2(config-if)# ip addr 192.168.23.2 255.255.255.0
R2(config-if)# no sh
R2(config-if)# exit

Router R3

R3(config)# int lo0
R3(config-if)# ip add 3.3.3.3 255.255.255.255
R3(config-if)# exit
R3(config)# int g0/0
R3(config-if)# ip add 192.168.23.3 255.255.255.0
R3(config-if)# no sh
R3(config-if)# exit

OSPF

Setelah selesai konfigurasi IP Address, kita lanjutkan pada konfigurasi utama yaitu OSPF single area.

Router R1

Catat terlebih dahulu IP Network yang terhubung langsung dengan Router, kemudian masukan dalam konfigurasi OSPF.
  • Network 1.1.1.1 Wildcard 0.0.0.0 Area 1
  • Network 192.168.12.0 Wildcard 0.0.0.255 area 1
Area yang saya gunakan adalah area 1.
R1(config)# router ospf 1
R1(config-router)# network 1.1.1.1 0.0.0.0 area 1
R1(config-router)# network 192.168.12.0 0.0.0.255 area 1
R1(config-router)# exit

Router R2

R2(config)# router ospf 1
R2(config-router)# network 2.2.2.2 0.0.0.0 area 1
R2(config-router)# network 192.168.23.0 0.0.0.255 area 1
R2(config-router)# network 192.168.12.0 0.0.0.255 area 1
R2(config-router)# exit

Router R3

R3(config)# router ospf 1
R3(config-router)# network 3.3.3.3 0.0.0.0 area 1
R3(config-router)# network 192.168.23.0 0.0.0.255 area 1
R3(config-router)# exit
Sampai disini maka konfigurasi OSPF sudah selesai, kita tinggal lakukan verifikasi.

Verifikasi

Setelah selesai konfigurasi OSPF, kita perlu melakukan verifikasi apakah konfigurasi sudah dilakukan dengan benar.

Database OSPF

Kita lihat database OSPF pada salah satu Router :
R1(config)#do sh ip ospf data               

            OSPF Router with ID (1.1.1.1) (Process ID 1)

  Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#                 Checksum Link count
1.1.1.1         1.1.1.1              987          0x80000005     0x0048DB 2
2.2.2.2         2.2.2.2             1016         0x80000007     0x004CB2 3
3.3.3.3         3.3.3.3              990          0x80000005     0x003AB8 2

  Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#                 Checksum
192.168.12.2    2.2.2.2         1016        0x80000003     0x008B21
192.168.23.3    3.3.3.3         990          0x80000003     0x003E56
Seperti yang kita lihat, Router R1 memiliki database informasi semua Router (Router Link States) dan informasi network yang ada pada topologi (Net Link States), semua informasi tersebut masuk dalam kategori LSA Tipe1
Student Terpelajar
Student Terpelajar Content Creator, Video Creator and Writer

Posting Komentar untuk "Konfigurasi OSPF Single area pada Router Cisco"